Tuesday, May 24, 2005

The current version of ActiveSync is not supported

While developing a Pocket PC or Smartphone application using Visual Studio 2005 Beta 2, you might get the following error:

"The current version of ActiveSync is not supported"

You'll also get this error when you try to connect to your device via Tools -> Connect to Device...

This happens because (as the error message rightly informs us) you don't have the latest version of ActiveSync installed. The latest "public" version is 3.8, while Visual Studio 2005 requires version 4.0. Microsoft has recently made the developer preview of ActiveSync 4.0 available, which can be downloaded from here

Monday, May 09, 2005